Início > JAVA > Problema ao iniciar o RAD no Linux – “Widget disposed too early”

Problema ao iniciar o RAD no Linux – “Widget disposed too early”

Pessoal, instalei o RAD 7.5 no Ubuntu Linux, ao selecionar a Workspace, obtenho o erro:

!ENTRY org.eclipse.ui.workbench 4 0 2009-10-10 18:44:28.933
!MESSAGE Widget disposed too early!
!STACK 0
java.lang.RuntimeException: Widget disposed too early!
at org.eclipse.ui.internal.WorkbenchPartReference$1.
widgetDisposed(WorkbenchPartReference.java:171)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:117)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1158)
-startup

A solução é adicionar a seguinte linha no eclipse.ini (que usualmente fica em /opt/IBM/SDP):

-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner

Fonte: http://employees.org/%7Eabhinav/blog/2009/10/getting-eclipse-3-4-x-working-on-ubuntu-karmic-beta/

Categorias:JAVA Tags:, , ,
  1. Nenhum comentário ainda.
  1. No trackbacks yet.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: